본문 바로가기

벌새::Security

2014년 5월 Microsoft 정기 보안 업데이트 (2014.5.14)

마이크로소프트(Microsoft) 업체에서 Windows Update 기능을 통해 매월 정기적으로 제공하는 2014년 5월 정기 보안 업데이트에서는 Microsoft Windows, Internet Explorer, Microsoft Office, Microsoft .NET Framework, Microsoft Server 소프트웨어, 생산성 소프트웨어 제품군에서 발견된 13건의 보안 취약점에 대한 8개의 보안 패치가 포함되어 있습니다.

이번 업데이트에서 주목할 부분은 Windows 셸 파일 연결 취약점(CVE-2014-1807)과 Internet Explorer 메모리 손상 취약점(CVE-2014-1815)을 이용하여 제한적인 공격이 발생하였으며, MS14-025 보안 패치로 해결된 Microsoft Windows 제품의 그룹 정책 기본 설정 암호 권한 상승 취약점(CVE-2014-1812)이 공개된 상태입니다.

또한 Windows 8 운영 체제용 Internet Explorer 10 버전과 Windows 8.1 운영 체제용 Internet Explorer 11 버전 웹 브라우저에 자체 내장된 Adobe Flash Player 플러그인에서 발견된 6건의 보안 취약점에 대한 보안 패치를 통해 Adobe Flash Player 13.0.0.214 버전으로 업데이트를 지원하고 있습니다.

2014년 5월 Microsoft Windows 악성 소프트웨어 제거 도구(MSRT)에서는 Win32/Filcout, Win32/Miuref 악성코드에 대한 진단이 추가되었습니다.

 

Win32/Filcout 악성코드는 2014년 4월부터 MSE 보안 제품에서 진단이 시작되었으며, filescout.exe 파일명을 가지는 FileScout 또는 File Scout라는 이름의 프로그램을 통해 다운로드되거나 Win32/Rotbrow 또는 Win32/Brantall 변종에 의해 감염이 이루어지고 있습니다.

 

감염된 환경에서는 바로가기 아이콘 생성 및 레지스트리 수정을 통해 사용자가 파일 오픈시 알려지지 "UnknownFile" 메시지창을 생성하여 추가적인 Win32/Sefnit 변종을 설치할 수 있습니다.

 

Win32/Miuref 악성코드는 2013년 12월부터 MSE 보안 제품에서 진단이 시작되었으며, 취약점을 통한 JS/Fiexp 악성 스크립트를 통한 감염, 스팸 메일 첨부 파일, SNS을 통해 유포된 Nullsoft 패커로 제작된 파일 실행시 감염이 발생하고 있습니다. 또한 Win32/Fareit, Win32/Onkods와 같은 악성코드에 의해 다운로드되어 설치될 수도 있습니다.

 

감염된 환경에서는 암호화된 .dll 파일을 .dat, .idx, .lck, .txt 확장자명으로 파일을 생성하여 시작 프로그램 레지스트리 값에 등록하여 자동 실행되도록 구성되어 있으며, 이를 통해 웹 브라우저 사용시 특정 사이트로 리다이렉트, 광고 생성, 원격 서버 연결을 시도합니다.

 

그러므로 2014년 5월 정기 보안 업데이트 후에는 Microsoft Windows 악성 소프트웨어 제거 도구(MSRT)를 실행하여 정밀 검사를 해보시길 권장합니다.

 

1. MS14-022 : Microsoft SharePoint Server의 취약점으로 인한 원격 코드 실행 문제점(2952166) - 긴급

  • CVE-2014-0251 : SharePoint 페이지 콘텐츠 취약점
  • CVE-2014-1754 : SharePoint XSS 취약점
  • CVE-2014-1813 : Web Applications 페이지 콘텐츠 취약점

이 보안 업데이트는 Microsoft Office 서버 및 생산성 소프트웨어에서 발견되어 비공개적으로 보고된 여러 취약점을 해결합니다. 인증된 공격자가 대상 SharePoint 서버에 특수하게 조작된 페이지를 보내는 경우 이러한 취약점으로 인해 원격 코드 실행이 허용될 수 있습니다.

 

2. MS14-023 : Microsoft Office의 취약점으로 인한 원격 코드 실행 문제점(2961037) - 중요

  • CVE-2014-1756 : Microsoft Office 중국어 문법 검사 취약점
  • CVE-2014-1808 : 토큰 재사용 취약점

이 보안 업데이트는 Microsoft Office에서 발견되어 비공개적으로 보고된 취약점 2건을 해결합니다. 가장 위험한 취약점으로 인해 사용자가 특수하게 조작된 라이브러리 파일과 동일한 네트워크 디렉터리에 있는 Office 파일을 열 경우 원격 코드 실행이 허용될 수 있습니다. 취약점 악용에 성공한 공격자는 현재 사용자와 동일한 권한을 얻을 수 있습니다. 시스템에 대한 사용자 권한이 적게 구성된 계정의 고객은 관리자 권한으로 작업하는 고객에 비해 영향을 적게 받습니다.

 

3. MS14-024 : Microsoft 공용 컨트롤의 취약점으로 인한 보안 기능 우회(2961033) - 중요

  • CVE-2014-1809 : MSCOMCTL ASLR 취약점

이 보안 업데이트는 MSCOMCTL 공용 컨트롤 라이브러리의 구현에서 비공개적으로 보고된 취약점을 해결합니다. 이 취약점으로 인해 사용자가 Internet Explorer와 같이 COM 구성 요소를 인스턴스화 할 수 있는 웹 브라우저에서 특수하게 조작된 웹 페이지를 볼 경우 보안 기능 우회가 허용될 수 있습니다. 웹 검색을 통한 공격의 경우, 이 취약점 악용에 성공한 공격자는 다양한 취약점 클래스로부터 사용자를 보호해 주는 ASLR(Address Space Layout Randomization) 보안 기능을 우회할 수 있습니다. 보안 기능을 우회하는 것만으로는 임의의 코드 실행이 허용되지 않지만 공격자는 이 ASLR 우회 취약점을 다른 취약점 즉, ASLR 우회를 통해 임의의 코드를 실행할 수 있는 원격 코드 실행 취약점 등과 함께 사용할

수 있습니다.

 

4. MS14-025 : 그룹 정책 기본 설정 취약점으로 인한 권한 상승 문제점(2962486) - 중요

  • CVE-2014-1812 : 그룹 정책 기본 설정 암호 권한 상승 취약점

이 보안 업데이트는 Microsoft Windows의 공개된 취약점을 해결합니다. Active Directory 그룹 정책 기본 설정을 사용하여 도메인 전체에서 암호를 배포하는 경우 이 취약점으로 인해 권한 상승이 허용되어 공격자가 그룹 정책 기본 설정에 저장된 암호를 검색하고 해독할 수 있습니다.

 

5. MS14-026 : .NET Framework의 취약점으로 인한 권한 상승 문제점(2958732) - 중요

  • CVE-2014-1806 : TypeFilterLevel 취약점

이 보안 업데이트는 비공개적으로 보고된 Microsoft .NET Framework의 취약점을 해결합니다. 이 취약점으로 인해 인증되지 않은 공격자가 특수하게 조작한 데이터를 .NET Remoting을 사용하는 영향을 받는 워크스테이션 또는 서버로 전송할 경우 권한 상승이 허용될 수 있습니다. .NET Remoting은 응용 프로그램에서 광범위하게 사용되고 있습니다. .NET Remoting을 사용하도록 특수하게 설계된 사용자 지정 응용 프로그램만 시스템을 이 취약점에 노출시킬 수 있습니다.

 

6. MS14-027 : Windows 셸 처리기의 취약점으로 인한 권한 상승 문제점(2962488) - 중요

  • CVE-2014-1807 : Windows 셸 파일 연결 취약점

이 보안 업데이트는 비공개적으로 보고된 Microsoft Windows의 취약점을 해결합니다. 이 취약점으로 인해 공격자가 ShellExecute를 사용하는 특수하게 조작된 응용 프로그램을 사용할 경우 권한 상승이 허용될 수 있습니다. 이 취약점을 악용하려면 공격자가 유효한 로그온 자격 증명을 가지고 로컬로 로그온 할 수 있어야 합니다.

 

7. MS14-028 : iSCSI의 취약점으로 인한 서비스 거부 문제점(2962485) - 중요

  • CVE-2014-0255, CVE-2014-0256 : iSCSI 대상 원격 서비스 거부 취약점

이 보안 업데이트는 Microsoft Windows에서 발견되어 비공개적으로 보고된 취약점 2건을 해결합니다. 이 취약점으로 인해 공격자가 대량의 특수하게 조작된 iSCSI 패킷을 대상 네트워크로 보낼 경우 서비스 거부가 발생할 수 있습니다. 이 취약점은 iSCSI 대상 역할이 사용된 서버에만 영향을 줍니다.

 

8. MS14-029 : Internet Explorer 보안 업데이트(2962482) - 긴급

  • CVE-2014-0310, CVE-2014-1815 : Internet Explorer 메모리 손상 취약점

이 보안 업데이트는 Internet Explorer에서 발견되어 비공개적으로 보고된 취약점 2건을 해결합니다. 이 취약점들은 모두 사용자가 Internet Explorer를 사용하여 특수하게 조작된 웹 페이지를 볼 경우 원격 코드 실행을 허용할 수 있습니다. 취약점 악용에 성공한 공격자는 현재 사용자와 동일한 권한을 얻을 수 있습니다. 시스템에 대한 사용자 권한이 적게 구성된 계정의 고객은 관리자 권한으로 작업하는 고객에 비해 영향을 적게 받습니다.

 

그 외에 Windows 7용 업데이트(KB2952664)를 통해 Windows 7 호환성 업데이트가 포함되어 있습니다.

 

그러므로 Windows 운영 체제 사용자는 반드시 Windows Update 기능을 통해 제공되는 모든 보안 패치를 모두 설치하시기 바라며, Windows XP 운영 체제는 2014년 4월 업데이트 이후부터는 더 이상의 보안 패치를 제공하지 않으므로 Windows 7 또는 Windows 8.1 운영 체제로 업그레이드를 하시기 바랍니다.