모질라(Mozilla) 재단에서 제공하는 오픈 소스 기반 Mozilla Firefox 웹 브라우저가 새로운 기능 추가, 버그(Bug) 수정 및 39건의 다중 보안 취약점 문제를 해결한 Mozilla Firefox 53.0 정식 버전을 업데이트 하였습니다.

 

 

  • Improved graphics stability for Windows users with the addition of compositor process separation (Quantum Compositor).
  • Two new 'compact' themes available in Firefox, dark and light, based on the Firefox Developer Edition theme.
  • Lightweight themes are now applied in private browsing windows.
  • Reader Mode now displays estimated reading time for the page.
  • Windows 7+ users on 64-bit OS can select 32-bit or 64-bit versions in the stub installer.

 

이번 Mozilla Firefox 53 버전에서는 Windows 운영 체제 사용자를 위한 더욱 빠르고 안정적인 성능 향상을 위한 Quantum 프로젝트의 일환으로 테마와 사이트의 허용 권한 등에 대한 새로운 디자인을 적용하였습니다.

 

 

 

기본 테마 외에 Compact Dark, Compact Light 테마가 추가되었으며, 해당 테마는 사생활 보호 창에서도 적용됩니다.

 

 

또한 Mozilla Firefox 웹 브라우저 설치 파일(Firefox Setup Stub)을 이용한 설치 과정에서 32비트 또는 64비트 버전을 선택할 수 있습니다.

 

그 외 세부적인 수정 사항은 Mozilla Firefox 53.0 Release Note 내용을 참고하시기 바랍니다.

 

보안 취약점 관련 업데이트에서는 Critical 등급(8건), High 등급(20건), Moderate 등급(7건), Low 등급(4건)에 대한 보안 패치가 포함되어 있습니다.

 

참고로 Mozilla Firefox 53 버전부터는 이미 지원이 종료된 Windows XP, Windows Vista 운영 체제에 대한 모든 지원이 종료됨에 따라 더 이상 설치할 수 없게 되었습니다.

 

그러므로 기존의 Mozilla Firefox 52 버전 사용자 중 Windows XP, Windows Vista 운영 체제 환경에서는 자동으로 Mozilla Firefox ESR 버전으로 업데이트가 이루어지며, 중요 Firefox 보안 패치에 대해서만 지속적으로 제공받을 수 있습니다.

 

Critical 등급

 

(1) CVE-2017-5429 : Memory safety bugs fixed in Firefox 53, Firefox ESR 45.9, and Firefox ESR 52.1

 

Mozilla developers and community members Christian Holler, Jon Coppeard, Marcia Knous, David Baron, Mats Palmgren, Ronald Crane, Bob Clary, and Chris Peterson reported memory safety bugs present in Firefox 52, Firefox ESR 45.8, and Firefox ESR 52. Some of these bugs showed evidence of memory corruption and we presume that with enough effort that some of these could be exploited to run arbitrary code.

 

(2) CVE-2017-5430 : Memory safety bugs fixed in Firefox 53 and Firefox ESR 52.1

 

Mozilla developers and community members Christian Holler, Jon Coppeard, Milan Sreckovic, Tyson Smith, Ronald Crane, Randell Jesup, Philipp, Tooru Fujisawa, and Kan-Ru Chen reported memory safety bugs present in Firefox 52 and Firefox ESR 52. Some of these bugs showed evidence of memory corruption and we presume that with enough effort that some of these could be exploited to run arbitrary code.

 

(3) CVE-2017-5433 : Use-after-free in SMIL animation functions

 

A use-after-free vulnerability in SMIL animation functions occurs when pointers to animation elements in an array are dropped from the animation controller while still in use. This results in a potentially exploitable crash.

 

(4) CVE-2017-5435 : Use-after-free during transaction processing in the editor

 

A use-after-free vulnerability occurs during transaction processing in the editor during design mode interactions. This results in a potentially exploitable crash.

 

(5) CVE-2017-5436 : Out-of-bounds write with malicious font in Graphite 2

 

An out-of-bounds write in the Graphite 2 library triggered with a maliciously crafted Graphite font. This results in a potentially exploitable crash. This issue was fixed in the Graphite 2 library as well as Mozilla products.

 

(6) CVE-2017-5459 : Buffer overflow in WebGL

 

A buffer overflow in WebGL triggerable by web content, resulting in a potentially exploitable crash.

 

(7) CVE-2017-5461 : Out-of-bounds write in Base64 encoding in NSS

 

An out-of-bounds write during Base64 decoding operation in the Network Security Services (NSS) library due to insufficient memory being allocated to the buffer. This results in a potentially exploitable crash. The NSS library has been updated to fix this issue to address this issue and Firefox 53 has been updated with NSS version 3.29.5.

 

(8) CVE-2017-5466 : Origin confusion when reloading isolated data:text/html URL

 

If a page is loaded from an original site through a hyperlink and contains a redirect to a data:text/html URL, triggering a reload will run the reloaded data:text/html page with its origin set incorrectly. This allows for a cross-site scripting (XSS) attack.

 

■ High 등급

 

(1) CVE-2017-5432 : Use-after-free in text input selection

 

A use-after-free vulnerability occurs during certain text input selection resulting in a potentially exploitable crash.

 

(2) CVE-2017-5434 : Use-after-free during focus handling

 

A use-after-free vulnerability occurs when redirecting focus handling which results in a potentially exploitable crash.

 

(3) CVE-2017-5437 : Vulnerabilities in Libevent library

 

Three vulnerabilities were reported in the Libevent library that allow for out-of-bounds reads and denial of service (DoS) attacks: CVE-2016-10195, CVE-2016-10196, and CVE-2016-10197. These were fixed in the Libevent library and these changes were ported to Mozilla code.

 

(4) CVE-2017-5438 : Use-after-free in nsAutoPtr during XSLT processing

 

A use-after-free vulnerability during XSLT processing due to the result handler being held by a freed handler during handling. This results in a potentially exploitable crash.

 

(5) CVE-2017-5439 : Use-after-free in nsTArray Length() during XSLT processing

 

A use-after-free vulnerability during XSLT processing due to poor handling of template parameters. This results in a potentially exploitable crash.

 

(6) CVE-2017-5440 : Use-after-free in txExecutionState destructor during XSLT processing

 

A use-after-free vulnerability during XSLT processing due to a failure to propagate error conditions during matching while evaluating context, leading to objects being used when they no longer exist. This results in a potentially exploitable crash.

 

(7) CVE-2017-5441 : Use-after-free with selection during scroll events

 

A use-after-free vulnerability when holding a selection during scroll events. This results in a potentially exploitable crash.

 

(8) CVE-2017-5442 : Use-after-free during style changes

 

A use-after-free vulnerability during changes in style when manipulating DOM elements. This results in a potentially exploitable crash.

 

(9) CVE-2017-5443 : Out-of-bounds write during BinHex decoding

 

An out-of-bounds write vulnerability while decoding improperly formed BinHex format archives.

 

(10) CVE-2017-5444 : Buffer overflow while parsing application/http-index-format content

 

A buffer overflow vulnerability while parsing application/http-index-format format content when the header contains improperly formatted data. This allows for an out-of-bounds read of data from memory.

 

(11) CVE-2017-5446 : Out-of-bounds read when HTTP/2 DATA frames are sent with incorrect data

 

An out-of-bounds read when an HTTP/2 connection to a servers sends DATA frames with incorrect data content. This leads to a potentially exploitable crash.

 

(12) CVE-2017-5447 : Out-of-bounds read during glyph processing

 

An out-of-bounds read during the processing of glyph widths during text layout. This results in a potentially exploitable crash and could allow an attacker to read otherwise inaccessible memory.

 

(13) CVE-2017-5448 : Out-of-bounds write in ClearKeyDecryptor

 

An out-of-bounds write in ClearKeyDecryptor while decrypting some Clearkey-encrypted media content. The ClearKeyDecryptor code runs within the Gecko Media Plugin (GMP) sandbox. If a second mechanism is found to escape the sandbox, this vulnerability allows for the writing of arbitrary data within memory, resulting in a potentially exploitable crash.

 

(14) CVE-2017-5454 : Sandbox escape allowing file system read access through file picker

 

A mechanism to bypass file system access protections in the sandbox to use the file picker to access different files than those selected in the file picker through the use of relative paths. This allows for read only access to the local file system.

 

(15) CVE-2017-5455 : Sandbox escape through internal feed reader APIs

 

The internal feed reader APIs that crossed the sandbox barrier allowed for a sandbox escape and escalation of privilege if combined with another vulnerability that resulted in remote code execution inside the sandboxed process.

 

(16) CVE-2017-5456 : Sandbox escape allowing local file system access

 

A mechanism to bypass file system access protections in the sandbox using the file system request constructor through an IPC message. This allows for read and write access to the local file system.

 

(17) CVE-2017-5460 : Use-after-free in frame selection

 

A use-after-free vulnerability in frame selection triggered by a combination of malicious script content and key presses by a user. This results in a potentially exploitable crash.

 

(18) CVE-2017-5464 : Memory corruption with accessibility and DOM manipulation

 

During DOM manipulations of the accessibility tree through script, the DOM tree can become out of sync with the accessibility tree, leading to memory corruption and a potentially exploitable crash.

 

(19) CVE-2017-5465 : Out-of-bounds read in ConvolvePixel

 

An out-of-bounds read while processing SVG content in ConvolvePixel. This results in a crash and also allows for otherwise inaccessible memory being copied into SVG graphic content, which could then displayed.

 

(20) CVE-2017-5469 : Potential Buffer overflow in flex-generated code

 

Fixed potential buffer overflows in generated Firefox code due to CVE-2016-6354 issue in Flex.

 

Moderate 등급

 

(1) CVE-2017-5445 : Uninitialized values used while parsing application/http-index-format content

 

A vulnerability while parsing application/http-index-format format content where uninitialized values are used to create an array. This could allow the reading of uninitialized memory into the arrays affected.

 

(2) CVE-2017-5449 : Crash during bidirectional unicode manipulation with animation

 

A possibly exploitable crash triggered during layout and manipulation of bidirectional unicode text in concert with CSS animations.

 

(3) CVE-2017-5450 : Addressbar spoofing using javascript: URI on Firefox for Android

 

A mechanism to spoof the Firefox for Android addressbar using a javascript: URI. On Firefox for Android, the base domain is parsed incorrectly, making the resulting location less visibly a spoofed site and showing an incorrect domain in appended notifications.

 

(4) CVE-2017-5451 : Addressbar spoofing with onblur event

 

A mechanism to spoof the addressbar through the user interaction on the addressbar and the onblur event. The event could be used by script to affect text display to make the loaded site appear to be different from the one actually loaded within the addressbar.

 

(5) CVE-2017-5462 : DRBG flaw in NSS

 

A flaw in DRBG number generation within the Network Security Services (NSS) library where the internal state V does not correctly carry bits over. The NSS library has been updated to fix this issue to address this issue and Firefox 53 has been updated with NSS version 3.29.5.

 

(6) CVE-2017-5463 : Addressbar spoofing through reader view on Firefox for Android

 

Android intents can be used to launch Firefox for Android in reader mode with a user specified URL. This allows an attacker to spoof the contents of the addressbar as displayed to users.

 

단, 해당 공격은 안드로이드(Android)용 Firefox 웹 브라우저에서만 영향을 줍니다.

 

(7) CVE-2017-5467 : Memory corruption when drawing Skia content

 

A potential memory corruption and crash when using Skia content when drawing content outside of the bounds of a clipping region.

 

■ Low 등급

 

(1) CVE-2017-5452 : Addressbar spoofing during scrolling with editable content on Firefox for Android

 

Malicious sites can display a spoofed addressbar on a page when the existing location bar on the new page is scrolled out of view if an HTML editable page element is user selected.

 

단, 해당 공격은 안드로이드(Android)용 Firefox 웹 브라우저에서만 영향을 줍니다.

 

(2) CVE-2017-5453 : HTML injection into RSS Reader feed preview page through TITLE element

 

A mechanism to inject static HTML into the RSS reader preview page due to a failure to escape characters sent as URL parameters for a feed's TITLE element. This vulnerability allows for spoofing but no scripted content can be run.

 

(3) CVE-2017-5458 : Drag and drop of javascript: URLs can allow for self-XSS

 

When a javascript: URL is drag and dropped by a user into the addressbar, the URL will be processed and executed. This allows for users to be socially engineered to execute an XSS attack on themselves.

 

(4) CVE-2017-5468 : Incorrect ownership model for Private Browsing information

 

An issue with incorrect ownership model of privateBrowsing information exposed through developer tools. This can result in a non-exploitable crash when manually triggered during debugging.

 

그러므로 Mozilla Firefox 웹 브라우저 사용자는 자동 업데이트(Firefox 메뉴 열기 → 도움말 메뉴 열기 → Firefox 정보) 기능을 이용하여 최신 버전으로 업데이트하시기 바랍니다.

신고
블로그 이미지

벌새

울지않는벌새가 되고 싶은 나..